Print

Your charts, strategies, indicators or Equilla codes do not have to be limited to your computer. All documents can be published right out of Tradesignal (as printouts or files), for example in Internet forums, print media or by E-Mail. In the other direction, it is also possible to import documents in Tradesignal from Internet forums or by E-Mail .

This way, you can exchange content with friends, colleagues and supervisors and work on Equilla code together, for example.

For exchanging complete packages, please see the chapters Export Packages and Import Packages.

Printing Charts and Tables


Print Overview

Edit Header/Footer

Edit Watermark
You can print all documents (Charts, Scanner, Watchlist, Equilla code etc.). Click on the Print button in the File menu. The Print Wizard opens. Here you can choose what in the currently selected workspace should be printed.

After selection, a Print Preview pane opens. Here you have the following options:
  • Print - Start the printing. The standard Windows printer dialog opens.
  • Copies - Number of copies of the workspace to print.
  • Printer - The printer to which to print.
  • Printer Properties - Advanced configuration of the selected printer.
  • Items to Print - List of items in the workspace to print (including an extra page containing the workspace as a whole. The items are printed in the order listed. The arrow buttons can be used to change the print order of the items.
  • Chart Scaling - Determines how charts should be scaled to fit the printed page.
  • Duplex Mode - Depending on the duplex/simplex capabilities of the printer.
  • Collation - Options to control how pages are collated.
  • Paper Size - Selection of the paper size.
  • Orientation - Portrait or landscape.
  • Color Mode - Select whether the document should be printed in Full Color (with transparency) (24 bit RGB with alpha channel), Full Color (without transparency) (24 bit RGB without alpha channel) or as Black and White. If the image is scaled on your printer (e.g. into a larger format), select Full Color (without transparency) for better results.
  • Margins - Some predefined margin options. Margins can also be manually adjusted using click and drag directly in the preview pane.
  • Edit Header/Footer - Shows the header/footer dialog where text and various macros can be set for the page header and footer. The alignment of text and font can also be changed. The following macros are available:
    • Document title
    • Page Number
    • Page Count
    • Print Date
    • Print Time
    • Print User
  • Edit Watermark - Show the watermark dialog where a watermark based on text or an image can be specified for each page on the printed output. The watermark dialog presents many options to configure how the watermark is displayed, including
    • Text, Text direction, Font, Color and Size.
    • Image file and alignment.
    • Translucency.
    • Positioned in front or behind.
    • Page range to apply watermark to.
For a chart and performance report, you can find additional print-out options in the toolbox, category Publish. You can change the axes' colors and the header.

The print options selected for a workspace will be remembered following printing. General options for printing (including setting a standard watermark and header/footer) are available in the options under File > Options > Personalize > Printing.

Print Schedule


Print Schedule
If you want to print documents on a regular basis, e.g. an overview of important indexes every morning, you can use the print scheduling function of Tradesignal. In the schedule, you can set up the printing of any number of documents at any date and time.

To be available for this function, the documents have to be saved as a package in workspaces. If the documents are not found there, either the wrong documents or none may be printed. Therefore, we recommend that you test each print schedule after its set-up.

To set up a print schedule
  1. Open the desired workspace
  2. Select File > Print
  3. Click on Add print schedule at the bottom left of the print pane to display the print schedule options
  4. Select the desired print schedule settings and click OK
The dialog will be dismissed and a new entry in the Schedule section of the print pane will be added. The buttons next to this entry can be used to edit or remove the schedule. Multiple schedules can be added for the same workspace.

If any workspaces have print scheduling set, a small print icon will be displayed above the Toolbar. Clicking on this button will display a dialog showing all scheduled printing jobs and provide buttons to edit or delete them.

Options for Scheduled Printing

When the print schedule settings dialog is displayed, the following options are available. Where there is no option for printing the setting chosen from the workspace print pane will be used.
  • Days - Which days of the week to print on.
  • Time - At which time to print. To print at multiple times on the same day, add a second print schedule.
  • Copies - How many copies of the document to print.
  • Items to print - This option gives various ways to print different items in a workspace
    • Items listed in the normal print settings
    • All items in the workspace
    • All charts in the workspace
    • All lists in the workspace (Watchlists, etc.)
    • All lists and all charts
  • Orientation - When not using the normal print settings, it is also possible to set the orientation for ptinting.
  • Alternate printer - It is possible to use either the printer settings from the normal print page, or to select an alternate printer, page size and duplex mode.
Click OK to save the print schedule settings.

Publishing with the Windows Chart Viewer

If you are often confronted with the task of creating publications with chart analysis, you can ease the work by using Tradesignal documents as Chart Viewer Object objects. This is a Windows Object that can be used in many programs, e.g. word processing.

In the following paragraphs, you can find the step-by-step instructions for MS Word (up to Word 2003) and MS Word 2007.

MS Word (up to Word 2003)

  1. Open your word processor.
  2. From the Insert menu, select the Object entry.
  3. From the list of objects, select Tradesignal Chart Viewer.
  4. Right-click on the newly appearing border in the text document. The context menu opens.
  5. From the context menu, select Tradesignal Chart Viewer Object and then select Properties from the submenu to edit those.
  • Here you have to enter the package in which the requested workspace is saved.For example:
    • Package: Tradesignal Files
    • Workspace: Chart Nasdaq
    You can edit the format of the graph by editing the height and width. It is possible to enter more than one chart in the new document.

    Save your document, e.g. as a template for your analysis. The name and folder can be freely chosen.

    When you open the document again, the following steps are necessary to update the graph.
    1. Start Tradesignal.
    2. Right-click in the graph in your document (e.g. in MS Word) to open the context menu.
    3. In the context menu, select the Properties of the Chart Viewer.
    4. Click on Update and then on OK.
    The chart is now refreshed with the data given by Tradesignal.

    MS Word 2007

    When using MS Word 2007, the "Developer" tab has to be available. If this is not the case, proceed as follows:
    1. Click on the Microsoft Office button and then click on [program] Options. The program is the name of the current program, i.e. "Word".
    2. Click on Popular and check Show Developer Tab in the Ribbon.
    3. Click on the tab Developer.
    4. In the controls, select Legacytools. Then, under More Controls, select TradeSignal Chart Viewer.
    In the configuration window, enter the package in which the requested workspace is saved.

    For example:
    • Package: Tradesignal Files
    • Workspace: Chart Nasdaq
    You can edit the format of the graph by editing the height and width. It is possible to enter more than one chart in the new document.

    Save your document, e.g. as a template for your analysis. The name and folder can be freely chosen.

    When you open the document again, the following steps are necessary to update the graph.
    1. Start Tradesignal.
    2. Right-click in the graph in your document (e.g. in MS Word) to open the context menu.
    3. In the context menu, select the Properties of the Chart Viewer.
    4. Click on Update and then on OK.
    The chart is now refreshed with the data given by Tradesignal.

    MS Word 2010+

    When using MS Word 2010 or above, the "Developer" tab has to be available. If this is not the case, proceed as follows:
    1. Click on the File tab on the toolbar and then click on Options.
    2. Click on Customize Ribbon and in the box on the far right that lists all ribbon tabs, check the option labelled Developer, then click OK.
    3. Click on the tab Developer.
    4. Ensure design mode is active by clicking on Design Mode button in the Controls group if it is not highlighted.
    5. In the Controls group, select Legacy Tools. Then, under More Controls, select Tradesignal Chart Viewer. The chart viewer object will be inserted into your document.
    6. Right-click on the inserted object and select Tradesignal Chart Viewer Object > Edit to show the properties dialog.
    In the properties dialog, enter the package in which the requested workspace is saved.

    For example:
    • Package: Tradesignal Files
    • Workspace: Chart Nasdaq
    You can edit the format of the graph by editing the height and width. It is possible to enter more than one chart in the new document.

    Save your document, e.g. as a template for your analysis. The name and folder can be freely chosen.

    When you open the document again, the following steps are necessary to update the graph.
    1. Start Tradesignal.
    2. Right-click in the graph in your document (e.g. in MS Word) to open the context menu.
    3. In the context menu, select the Properties of the Chart Viewer.
    4. Click on Update and then on OK.
    The chart is now refreshed with the data given by Tradesignal.

    Please note: ActiveX Objects and Add-Ins from third-parties, will generally not work with 64-bit versions of Microsoft Office.