Toolbar


Toolbar
In Tradesignal, the classic menu is substituted with a Ribbon-style Toolbar.
  • There are multiple tab-pages of toolbar buttons and menus organized according to general functionality.
  • The first tab is the File menu, that will show the backstage view of the application when selected. The backstage view is an interactive menu that contains all functions that operate on a workspace as a whole (for example printing).
  • The Home tab contains the majority of functions that pertain to the contents of a workspace.
  • The remaining tabs contain the functions implied by their title. Insert for commands concerning inserting content into a workspace. Layout for workspace layout commands. Order routing for functions concerned with order routing.
  • The final tab Editor will only appear if a text editor is selected in a workspace. This tab has all functions concerned with editing Equilla or HTML source code and debugging Equilla content in charts.
  • Some buttons open menus that offer further functions. You can recognize these by the small black arrow below the buttons.
  • The arrangement of the buttons in the toolbar changes depending on the monitor or program window size. Therefore, either more buttons or fewer buttons (but with menu functionality) are visible.
  • For many functions, you can open a help topic. The help is available via the key F1 if the tool tip says that there is a help file for this feature. The help topic is then displayed in the internal browser.
  • You can toggle the Toolbar with the keyboard shortcut Ctrl + F1, by double-clicking on a Toolbar tab or by clicking the small arrow on the far right of the toolbar tabs. When collapsed the toolbar can be temporarily shown by clicking on one of the toolbar tabs.

Toolbar Tabs and Groups

The functions displayed on a Toolbar tab are further organized into named groups to improve identification. The following groups are available by toolbar tab:

File Tab

This tab shows the backstage view, which combines typical file operations like save and open with interactive inline content organized as sub menus:
  • Recent - List of recently opened workspaces.
  • Print - Print preview and printing.
  • Save & Send - Functions to export the current workspace in various ways and formats.
  • Help - The application Help menu.
  • Options - All application configuration options.

Home Tab

  • Edit - The typical clipboard functions like copy and paste.
  • Strategies - Functions to add and augment trading system components.
  • Table - Functions concerning table-based elements.
  • Data - Functions associated with searching for - and manipulating - financial data.
  • Chart - Functions concerned with chart document.
  • Chart Tools - Drawing tools for use in charts.
  • Favorites - Any indicators with short codes that have been color-tagged will be listed here.
  • Style - Operations for creating and applying styles and templates to workspace elements.
  • Find - Search for items withing open workspace elements.

Insert Tab

  • Charts - Chart-like items that can be inserted into a workspace.
  • Tables - Table-based items that can be inserted into a workspace.
  • Trading - Trading-system related elements.
  • Research - Research tools.
  • Developer - Developer specific tools.

Layout Tab

  • Layout - Functions to change the layout of the current workspace
  • Monitors - Options to utilize multiple monitors.

Order Routing Tab

  • Order Routing - Functions to control and configure automatic order routing.

Editor Tab

  • Edit - The typical clipboard functions like copy and paste.
  • Text Editor - Functions found in a typical developer text editor
  • Export - Options to export an Equilla script in various ways.
  • Find - Typical search (and replace) operations.
  • Debug - Commands to control the Equilla Debugger.
  • Breakpoints - Set and manage breakpoints for use when debugging.