Workspaces

The workspace is the area of a software desktop in which documents are open and editable. Tradesignal workspaces provide many special functions to make using the software easier for you.

You can use workspaces for the following:
  • Editing and saving several charts at the same time
  • Arranging charts in groups
  • Saving different documents like charts, scanners, portfolios and editors as one workspace
  • Working with several desktops and monitors at the same time

Work with Workspaces

New Workspace

Tradesignal always opens a new workspace if you start a new document on an empty desktop.

You can also use the following methods to set up new workspaces manually:
  • Click the New button in the File menu.
  • Press the key combination Ctrl + N.
  • Click on New in the context menu of the workspace tab.
  • Click on the plus (+) button next to the workspace tabs at the bottom of the screen.
A new workspace is opened. A new workspace tab appears on the lower left.

Open Workspace

You can only open saved workspaces. Otherwise, you can always set up a new workspace.

Open a saved workspace:
  • By opening the Workspaces manager in the toolbox and double-clicking a list entry or
  • By clicking on Recent in the File menu and choosing a workspace from the list of last edited workspaces. If you click on the entry More..., a file dialog opens in which you can open, copy or move workspaces.
    When you press the key combination Ctrl + O, a general file dialog opens in which you have access not only to workspaces but also to indicators, strategies, functions etc. In both dialogs you have the possibility to select and open more than one workspace at once.
As an additional feature, you can open workspaces via the context menu of packages. For that, the packages have to be displayed. Right-click on the package name and select either
  • Open All Workspaces to open all workspaces in this package or
  • Open All Yellow Workspaces (red, blue) to open the color-tagged ones only.
For color-tagging workspaces in the toolbox, see the chapter Toolbox.

Rename Workspace

To rename a workspace, open the context menu of the workspace tab and click on Rename. A dialog opens in which you can enter a new name for the workspace.

Close Workspace

To close a single workspace, choose one of the following options:
  • Press the key combination Ctrl + Shift + F4.
  • Click on Close Workspace in the context menu of the workspace tab or in the file menu.
  • Click on the x button on the tab of the workspace.
To close all workspaces, click on Close all Workspaces in the file menu.

The last closed workspace can be quickly restored using the Restore Removed Items feature.

Save Workspace

To save workspaces, choose one of the following entries in the file menu:
  • Save (Ctrl + S) to save the current workspace (also available in the tab context menu).
  • Save as to save the current workspace under another name.
  • Save all to save all open workspaces.
You can find all saved workspaces in the Workspaces manager of the toolbox.

Delete Workspace

You can only delete workspaces that have been saved. Otherwise you can simply close a workspace that is no longer useful.

To delete a saved workspace, open the Workspaces manager in the toolbox for a list of saved workspaces. Choose Delete from the context menu of an entry.

Navigate in Workspaces

You can browse through open workspaces by pressing Ctrl + W for forward and Ctrl + Q for backward scrolling.

You can change the workspace sequence by clicking on a tab and dragging and dropping it to the left or right.

Note: If you want to see all open workspaces at a glance in multiple line, select Multiline in the context menu of the workspace.

Define Keyboard Shortcuts

You can assign the keyboard shortcuts Ctrl + 0 up to 9 for often used workspaces. For this, either:
  • Right-click on the workspace tab or
  • Right-click in the list of workspaces in the Workspace manager in the toolbar
and choose Set Shortcut to select a key command from the sub-menu.

Arrange Workspaces on Monitors

You can move a workspace to another monitor by clicking the workspace tab and dragging and dropping it to the target monitor.

You can also arrange the workspaces on more than one monitor by clicking on the Layout button in the toolbar and choosing up to ten monitors to distribute the workspaces.

Arrange Workspaces on Desktops

You can display workspaces on new desktops. Desktops are new windows that will appear in the Windows task bar. They only offer the context menus of workspace bar and chart.

To display a workspace on a different desktop, right-click the workspace tab, then choose Change Desktop from the sub-menu to select a desktop. Alternative you can drag-and-drop the workspace tab to the according desktop.

You can move the new desktop to other monitors by dragging and dropping.

Lock Layout against Changes

To prevent unwanted changes in the layout design of your workspaces, either
  • click the Layout toolbar tab and click on Lock, or
  • right-click the workspace tab and choose Lock from the context menu.
Documents in a locked workspace cannot be changed in size, form or position.

To unlock the workspace, simply click on the toolbar button a second time.

Password Protection


Password Protection dialog
You can restrict access to a workspace by specifying passwords for opening and editing it by selecting the Layout toolbar tab and clicking on Password Protect...

Important: The password cannot be recovered, so if you lose it, you will not be able to edit/access your protected workspace anymore.

Organize Documents in Workspaces

Default Layouts


Layout "Tiled" documents

Layout "Tabs" (stacked documents
Tradesignal offers several default layouts for documents on a workspace. You can find them by selecting the Layout tab on the toolbar.

Rebalance arranges the documents as homogeneous as possible on the workspace.

Tabbed arranges all documents in a single stack. Each document is accessible via a tab.

Columns arranges all documents in a row.

Rows arranges all documents in a vertical column.

Tiled generates a checker-board pattern of the open documents. The documents are arranged as homogeneously as possible in size and position.

Maximize (key F4) shows the active document in full size in the workspace. A double-click on the document tab will also maximize the document. Repeat to return to the former arrangement.

You can change the size of a single document by moving the frame of the document to the left, right, up or down.

Move Documents

You can move documents across the workspace by dragging and dropping the document tab to a new position. During dragging, the position is marked by a black, rectangular frame.

In principle, documents can be placed to the left, right, above or below another document.

In addition, you can place a document over another one, which results in a document stack. In this case, two tabs will be offered in the document space. The following rules apply to stacked documents:
  • Click on the document tab to bring the document to the front of the stack, i.e. display.
  • Drag the document tab to the left or right to change the position of the document in the stack.

Quick Navigation between Documents

A document is activated when you click on its tab or frame.

You can also use keyboard commands for quickly switching between documents (especially when stacked):
  • Ctrl + Tab switches to the next document in the workspace. If documents are stacked, the next document in the stack is displayed.
  • Ctrl + Shift + Tab switches to the previous document in the workspace. If documents are stacked, the previous document in the stack is displayed.

Copy and Paste Documents

In a workspace, you can copy documents and then paste them into another or the same workspace, duplicating it.
  1. Activate a document by clicking on its tab or frame.
  2. In the Edit group in the Home tab of the Toolbar, click on the button Copy (keyboard shortcut Ctrl + C).
  3. If necessary, switch to another workspace and click on the button Paste (keyboard shortcut Ctrl + V).

Symbol Linking


Link Documents
You can link several documents so that in all documents the same symbol or period is displayed. The links are connected to colors, which are displayed as small filled rectangles on the top left of the document tab.

You can find the linking possibilities in the context menu of the document tab:
  • Symbol Linking: When you change the symbol of a linked document, the symbol is changed in all linked documents.
  • Period Linking: When you change the period of a linked document, the period is changed in all linked documents.
You have the choice between
  • Six normal links: these links only apply within the same workspace.
  • Three global links: these links apply across all workspaces.
Note that you can assign only one document and one period link per document.
  • Global component linking: In addition to linking components within a single workspace, a component can be marked with a ‘global link’. The effect of this is that whenever a globally linked item is changed (either the symbol or period replaced), all other components in all open workspaces with the same global link color will also be updated.

Restoring Removed Items

When a workspace or item in a workspace is closed, or an item from a chart or watchlist is deleted, a yellow popup window will be displayed at the bottom of the application window with a button labelled Unremove. This button may be clicked to undo the last remove/delete operation. Clicking the x button on the popup window will hide it without performing the undo operation (a new link labelled Unremove will instead be displayed to the left of the clock at the top right of the application window).

To only show the unobtrusive link at the top right of the application window, uncheck the corresponding box in the options found under File > Options > Advanced > Workspaces.